1. Duyuruyu Kapat

Linux'ta apt-get update ve python3 sorunu

'Linux Diğer' forumunda linux_er tarafından 26 Temmuz 2016 tarihinde açılan konu

  1. linux_er

    linux_er New Member

    Katılım:
    26 Temmuz 2016
    Mesaj:
    1
    Beğeniler:
    0
    Ödül Puanları:
    0
    Merhaba arkadaşlar. Baştan söyliyim Linux'ta biraz yeniyim; kavramları hatalı kullanırsam, mazur görün. Linux'ta python3 kurmak isterken arşivi update etmekle başladım ama hata veriyor. sudo apt-get update komutuna karşılık ;

    E: The method driver /usr/lib/apt/methods/https could not be found.
    N: Is the package apt-transport-https installed?

    böyle bişey çıkıyor. Buna benzer hatalarla arşivden dosya yüklemeye çalışırken hep karşılaşıyorum. Sorun tam olarak nedir acaba yardımcı olursanız sevinirim. Ayrıca python3 ü nasıl kuracağım konusunda da yardımcı olursanız çok iyi olur.
     
  2. heLL

    heLL New Member

    Katılım:
    14 Haziran 2016
    Mesaj:
    5
    Beğeniler:
    0
    Ödül Puanları:
    0
    Selam,

    leafpad /etc/apt/sources.list dosyasının içindeki repoların başında https yazıyorsa onları http yaparak deneyebilirmisin?

    ayrıca "deb http://http.kali.org...." şeklideyse onlarıda "deb http://repo.kali.org...." şeklinde değiştirebilirsin

    Eğer sıkıntı yaşamaya devam edersen sources.list içeriğini aşağıdaki gibi değiştirebilirsin;
    deb http://repo.kali.org/kali kali-rolling main contrib non-free
    deb-src http://repo.kali.org/kali kali-rolling main contrib non-free

    bu işlemleri yaptıktan sonra apt-get update çalışıyor olması lazım,

    bir çözüm yoluda;
    http://unix.stackexchange.com/quest...-usr-lib-apt-methods-https-could-not-be-found

    linux kalide python3 standart olarak yüklü gelir, python3 -V komutu ile versiyonuna bakabilirsin.

    yüklü değilse update işleminden sonra 3.5.2 versiyonu yükleniyor.
     

Bu Sayfayı Paylaş

Share