Kali Linux Python Paket yükleme Hatası

'BackTrack' forumunda Comedy tarafından 7 Kasım 2019 tarihinde açılan konu

  1. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    S.Aleyküm dostlar.
    Çoooookkk uzun bir aradan sonra, tekrar burda olmak çok güzel.

    burda olmadan yaptığımız onca zaman kaybına üzülüyorum :)

    neyse bl bol artık görüşme vaktimiz olacak. çünkü artık online olma vakti geldi :)

    geldi gelmesinede Kali linux kullanmayalı baya olmuştu.

    üzerinden çok zaman geçti ve bilgi seviyemiz gene sıfırlandı.

    malum yaş kemale erdi :p

    şimdi konumuza dönecek olursak şöyle anlatalım..

    Kod:
    root@Sincap:~# python3
    Python 3.7.5 (default, Oct 27 2019, 15:43:29)
    [GCC 9.2.1 20191022] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>>
    

    Kod:
    root@Sincap:~# python2
    Python 2.7.17 (default, Oct 19 2019, 23:36:22)
    [GCC 9.2.1 20191008] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>>
    
    
    yukarda ki kodlarda gördüğünüz gibi zaten Kali linux da python yüklüde geldiğinden dolayı

    hem python2 hemde python3 hali hazırda mevcut.

    şimdi python3 paketlerinden herhangi birini yüklemeye çalıştığımda,
    doğal olarak python2 hatası veriyor.. ancak pip3 install yaptığımda yine herhangi bir değişiklik göstermiyor.

    hata kodu aşşağıda

    Kod:
    root@Sincap:~# pip3 install docx
    Traceback (most recent call last):
      File "/usr/local/bin/pip3", line 6, in <module>
        from pkg_resources import load_entry_point
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3250, in <module>
        @_call_aside
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3234, in _call_aside
        f(*args, **kwargs)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
        working_set = WorkingSet._build_master()
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 583, in _build_master
        ws.require(__requires__)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 900, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 786, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'pip==19.3.1' distribution was not found and is required by the application
    root@Sincap:~#
    
    aslen sabit olarak neden python2 çıkıyor karşıma ?

    bilen varmı ecep
     
  2. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    makineyi bozdum :D

    şimdi yukardaki sorunu hallettim ancak birde bu çıktı :D

    Kod:
    root@Sincap:~# sudo pip install docx
    Could not find platform independent libraries <prefix>
    Could not find platform dependent libraries <exec_prefix>
    Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
    ImportError: No module named site
    root@Sincap:~#
    
     
  3. MrX

    MrX Active Member

    Katılım:
    22 Mart 2016
    Mesaj:
    846
    Beğeniler:
    42
    Ödül Puanları:
    28
    Şehir:
    Belirtilmemiş
    Dostum öncelikle
    terminali açıp şu komutları uygularmısın
    Kod:
    ls /usr/local/lib
    XXX yazan yere hangi sürümde hata yaşıyorsanız mesela 2.7 - 3.5 - 3.6 gibi değiştirimisin

    Kod:
    export PYTHONPATH=/usr/local/lib/pythonXXX
    Dostum eğer yine hata verirse başka bir çözüm yolu ararız selametle :)
     
  4. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    malesef işe yaramadı yaw

    upgrade bile çalışmıyor.

    Kod:
    root@Sincap:~# ls /usr/local/lib
    python2.7  python3.7
    root@Sincap:~# export PYTHONPATH=/usr/local/lib/python2.7
    root@Sincap:~# export PYTHONPATH=/usr/local/lib/python3.7
    root@Sincap:~# guncelle
    Paket listeleri okunuyor... Bitti
    Bağımlılık ağacı oluşturuluyor       
    Durum bilgisi okunuyor... Bitti     
    Bu sorunları düzeltmek için 'apt --fix-broken install' komutunu çalıştırmanız gerekebilir.
    Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
    libsmbclient : Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                    Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    samba : Bağımlılıklar: python3-samba ama kurulu değil
             Bağımlılıklar: samba-common (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
             Bağımlılıklar: libldb2 (>= 2:2.0.7~) ama kurulu değil
             Bağımlılıklar: libtdb1 (>= 1.4.2~) ama 1.3.16-2+b1 kurulu
             Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
             Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    samba-common-bin : Bağımlılıklar: python3-samba ama kurulu değil
                        Bağımlılıklar: samba-common (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                        Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                        Bağımlılıklar: libtdb1 (>= 1.4.2~) ama 1.3.16-2+b1 kurulu
                        Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    samba-dsdb-modules : Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                          Bağımlılıklar: libldb2 (< 2:2.0.8~) ama kurulu değil
                          Bağımlılıklar: libldb2 (> 2:2.0.7~) ama kurulu değil
                          Bağımlılıklar: libtdb1 (>= 1.4.2~) ama 1.3.16-2+b1 kurulu
                          Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    samba-vfs-modules : Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                         Bağımlılıklar: libtdb1 (>= 1.4.2~) ama 1.3.16-2+b1 kurulu
                         Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    smbclient : Bağımlılıklar: samba-common (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                 Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
                 Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    winexe : Bağımlılıklar: libwbclient0 (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
              Bağımlılıklar: samba-libs (= 2:4.11.1+dfsg-2) ama 2:4.9.11+dfsg-1 kurulu
    E: Karşılanmamış bağımlılıklar. 'apt --fix-broken install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin).
    root@Sincap:~#
    
     
  5. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    mesela yukardaki hatalardan biri bazı dosyaların kurulu olmadığını gösteriyor.

    ancak kurulu olmayan dosyalarıda kurmaya çaışınca
    Kod:
    root@Sincap:~# pip install libldb2
    Could not find platform independent libraries <prefix>
    Could not find platform dependent libraries <exec_prefix>
    Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
    ImportError: No module named site
    root@Sincap:~#
    
    bu hatayla karşılaşıyorum..
     
  6. MrX

    MrX Active Member

    Katılım:
    22 Mart 2016
    Mesaj:
    846
    Beğeniler:
    42
    Ödül Puanları:
    28
    Şehir:
    Belirtilmemiş
    ilk önce bunu uygularmısın
    Kod:
    apt --fix-broken install
    Sonrasındada
    Kod:
    apt update
    apt upgrade
    
    
    apt-get update
    apt-get upgrade
    bunları uyguladıktan sonra tekrar lib1db2 yi indirmeyi denermisin
    belki bu sefer çözülür :)
     
  7. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    aklına gelebilecek herşeyi yaptım ve pes ettim :D

    yeniden format atmak zorunda kaldım ve attım şu an mutlu ve mesudum :D
     
    MrX bunu beğendi.
  8. MrX

    MrX Active Member

    Katılım:
    22 Mart 2016
    Mesaj:
    846
    Beğeniler:
    42
    Ödül Puanları:
    28
    Şehir:
    Belirtilmemiş
    :D bazen en iyi çözüm format oluyor Dostum sorun çözüldüyse ne güzel :)
     
    Comedy bunu beğendi.
  9. Comedy

    Comedy Albay

    Katılım:
    15 Ağustos 2015
    Mesaj:
    105
    Beğeniler:
    3
    Ödül Puanları:
    18
    Şehir:
    Belirtilmemiş
    eyvallah :)

    ayrıca sen CW deki MrX misin
     
    MrX bunu beğendi.
  10. MrX

    MrX Active Member

    Katılım:
    22 Mart 2016
    Mesaj:
    846
    Beğeniler:
    42
    Ödül Puanları:
    28
    Şehir:
    Belirtilmemiş
    Hayır Dostum Malesef o nick doluydu :/
    Bende uzun zamandan beri haber alamadığım Dostumun anısını yaşatmak için MenIn nickini kullandım
    :)
     

Bu Sayfayı Paylaş